File Buddy 9.0.2 Universal
For all users of Mac OS X 10.3 - 10.5
2.4 MB .dmg

System Requirements for File Buddy 9
File Buddy 9 requires Mac OS X 10.3.9 or later and is fully compatible with Mac OS X 10.4 on both PowerPC and Intel. Compatible with 10.5, though a few minor issues have been reported in Leopard and are being investigated. File Buddy 7 is still available if you are using Mac OS 9 or Mac OS X 10.1 – 10.2.8.

File Buddy is not shareware and may not be made available on other sites for download or distributed by any means without the express permission of SkyTag Software. By downloading File Buddy you acknowledge that you agree to the terms of our download agreement.

Since 1993

Last updated June 12, 2012